poj 2225 Asteroids!【BFS】

Asteroids!
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3087   Accepted: 1161

Description

You're in space.  
You want to get home.  
There are asteroids.  
You don't want to hit them.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.  

A single data set has 5 components:  
  1. Start line - A single line, "START N", where 1 <= N <= 10. 
  2. Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values: 
    • 'O' - (the letter "oh") Empty space  
      'X' - (upper-case) Asteroid present

  3. Starting Position - A single line, "A B C", denoting the [A,B,C] coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces. 
  4. Target Position - A single line, "D E F", denoting the [D,E,F] coordinates of your target's position. The coordinate values will be integers separated by individual spaces. 
  5. End line - A single line, "END"

The origin of the coordinate system is [0,0,0]. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.  

The first coordinate in a set indicates the column. Left column = 0.  
The second coordinate in a set indicates the row. Top row = 0.  
The third coordinate in a set indicates the slice. First slice = 0.  

Both the Starting Position and the Target Position will be in empty space.  

Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.  

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.  

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.  

Sample Input

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

Sample Output

1 0
3 4
NO ROUTE

三维广搜搜索

给一个三维空间的规格n * n * n;

给出空间中的结构,然后给两个坐标,问能不能从一个坐标走到另一个坐标,如果能,输出三维空间的规模n和要走的最少步数,如果不能,直接输出“NO ROUTE”.

注意:最后输入的坐标顺序是(c, b, a),

已Accept代码【c++提交】

#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;

int dx[] = {1, -1, 0, 0, 0, 0};
int dy[] = {0, 0, 1, -1, 0, 0};
int dz[] = {0, 0, 0, 0, 1, -1};
char str[5];
char s, ss[4];
int n;
int x, y, z;
int a, b, c;
bool map[11][11][11];//用bool型,节约空间【自己想想为什么】
int dis[11][11][11];
struct node {
	int x, y, z;
	node() {}
	node(int x, int y, int z) : x(x), y(y), z(z) {}
};

void BFS() {
	queue <node> Q;
	memset(dis, 0x3f3f3f, sizeof(dis));
	Q.push(node(a, b, c)) ;
	dis[a][b][c] = 0;
	while(!Q.empty()) {
		node tmp = Q.front();
		Q.pop();
		int nx = tmp.x;
		int ny = tmp.y;
		int nz = tmp.z;
		for(int i = 0; i < 6; i++) {
			int sx = nx + dx[i];
			int sy = ny + dy[i];
			int sz = nz + dz[i];
			if(sx < 0 || sx >= n || sy < 0 || sy >= n || sz < 0 || sz >= n || map[sx][sy][sz] == true)
				continue;
			if(dis[sx][sy][sz] > dis[nx][ny][nz] + 1) {
				dis[sx][sy][sz] = dis[nx][ny][nz] + 1;
				Q.push(node(sx, sy, sz));
			}
		}
	}
	if(dis[x][y][z] > 1000)
		printf("NO ROUTE\n");
	else
		printf("%d %d\n", n, dis[x][y][z]);
}

int main() {
	while(scanf("%s%d", str, &n) != EOF) {
		for(int i = 0; i < n; i++)
			for(int j = 0; j < n; j++) {
				getchar();
				for(int k = 0; k < n; k++) {
					scanf("%c", &s);
					if(s == 'O')
						map[i][j][k] = false;
					else
						map[i][j][k] = true;
				}
			}
		scanf("%d%d%d", &c, &b, &a);
		scanf("%d%d%d", &z, &y, &x);
		scanf("%s", ss);
		BFS();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/nailnehc/article/details/49951369
今日推荐