PAT乙级刷题/1054 求平均数/C++实现

 一、题目描述

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

二、题解代码以及提交截图

代码一:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main() {
    int n, cnt = 0;
    char a[50], b[50];
    double temp, sum = 0.0;
    cin >> n;
    for(int i = 0; i < n; i++) {
        scanf("%s", a);
        sscanf(a, "%lf", &temp);
        sprintf(b, "%.2f",temp);
        int flag = 0;
        for(int j = 0; j < strlen(a); j++)
            if(a[j] != b[j]) flag = 1;
        if(flag || temp < -1000 || temp > 1000) {
            printf("ERROR: %s is not a legal number\n", a);
            continue;
        } else {
            sum += temp;
            cnt++;
        }
    }
    if(cnt == 1)
        printf("The average of 1 number is %.2f", sum);
    else if(cnt > 1)
        printf("The average of %d numbers is %.2f", cnt, sum / cnt);
    else
        printf("The average of 0 numbers is Undefined");
    return 0;
}

代码二:

#include <iostream>
#include <iomanip>
using namespace std;

bool isNumber(const string& s){
    istringstream sin(s);
    double test;
    return sin >> test && sin.eof();
}

int main(){
    int n;
    cin >> n;
    string str;
    double sum = 0;
    int count = 0;
    for (int i=0; i<n; i++){
        bool islegal = true;
        cin >> str;
        double d = 0;
        if (isNumber(str)){
            d = stod(str);
            if (d<-1000 || d>1000){
                islegal = false;
            }
            else{
                int pos = str.find('.');
                if (pos!=string::npos && str.length()-3>pos){
                    islegal = false;
                }
            }
        }
        else{
            islegal = false;
        }

        if (islegal){
            count++;
            sum += d;
        }
        else {
            cout << "ERROR: " << str << " is not a legal number" << endl;
        }
    }

    if (count==0){
        cout << "The average of 0 numbers is Undefined" << endl;
    }
    else if (count==1){
        cout << "The average of 1 number is " << fixed << setprecision(2) << sum << endl;
    }
    else{
        cout << "The average of " << count << " numbers is " << fixed << setprecision(2) << sum / count << endl;
    }
    return 0;
}

PAT 

猜你喜欢

转载自blog.csdn.net/m0_50829573/article/details/121790880