Hdu.2504.又见GCD

F - 又见GCD

Time Limit: 1000 MS Memory Limit: 32768 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status]

Description

有三个正整数a,b,c(0<a,b,c<10^6),其中c不等于b。若a和c的最大公约数为b,现已知a和b,求满足条件的最小的c。

Input

第一行输入一个n,表示有n组测试数据,接下来的n行,每行输入两个正整数a,b。

Output

输出对应的c,每组测试数据占一行。

Sample Input

2
6 2
12 4

Sample Output

4
8

#include<iostream>
using namespace std;

int gcd(int a,int b){
    return b?gcd(b,a%b):a;
}

int main(){
    int T;cin>>T;
    int a,b;
    while(cin>>a>>b){
        int ans=2*b;
        while(gcd(a,ans)!=b){
            ans+=b;
        }
        cout<<ans<<endl;
    }
}





猜你喜欢

转载自blog.csdn.net/xxxxxm1/article/details/80289255
今日推荐