UVA 11400 照明系统设计(思维dp)

You are given the task to design a lighting system for a huge conference hall. After doing a lot of calculation and sketching, you have figured out the requirements for an energy-efficient design that can properly illuminate the entire hall. According to your design, you need lamps of n different power ratings. For some strange current regulation method, all the lamps need to be fed with the same amount of current. So, each category of lamp has a corresponding voltage rating. Now, you know the number of lamps and cost of every single unit of lamp for each category. But the problem is, you are to buy equivalent voltage sources for all the lamp categories. You can buy a single voltage source for each category (Each source is capable of supplying to infinite number of lamps of its voltage rating.) and complete the design. But the accounts section of your company soon figures out that they might be able to reduce the total system cost by eliminating some of the voltage sources and replacing the lamps of that category with higher rating lamps. Certainly you can never replace a lamp by a lower rating lamp as some portion of the hall might not be illuminated then. You are more concerned about money-saving than energy-saving. Find the minimum possible cost to design the system.
Input Each case in the input begins with n (1 ≤ n ≤ 1000), denoting the number of categories. Each of the following n lines describes a category. A category is described by 4 integers - V (1 ≤ V ≤ 132000), the voltage rating, K (1 ≤ K ≤ 1000), the cost of a voltage source of this rating, C (1 ≤ C ≤ 10), the cost of a lamp of this rating and L (1 ≤ L ≤ 100), the number of lamps required in this category. The input terminates with a test case where n = 0. This case should not be processed.
Output
For each test case, print the minimum possible cost to design the system.
Sample Input
3 100 500 10 20 120 600 8 16 220 400 7 18 0
Sample Output
778

#include<iostream>
#include<algorithm>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<set>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define maxn 1003
#define INF 10000000
using namespace std;
int n,dp[maxn];
struct node
{
    int vv,kk,cc,ll;
    node(){}
};
node seq[maxn];
/*
时间复杂度O(n^2),
dp主要枚举的是
把前面i-j类物品都换成i类物品后的最小值,
对j进行循环遍历。

这样做的正确性在于:
dp[i]重点对象在用i进行交换后得到的最大值,
如果利用在i之前的物品进行等价交换,
则早在dp[j]时就已经计算出来了,基于这个现象,
只要枚举从j到i的连续段即可
*/

bool cmp(node x,node y)
{
    return x.vv<y.vv;
}

int main()
{
    ios::sync_with_stdio(false);
    while(scanf("%d",&n)&&n)
    {
           for(int i=0;i<n;i++)
               scanf("%d%d%d%d",&seq[i].vv,&seq[i].kk,&seq[i].cc,&seq[i].ll);
            sort(seq,seq+n,cmp);

               int s[maxn];s[0]=seq[0].ll;
               for(int i=1;i<n;i++)   s[i]=s[i-1]+seq[i].ll;

               dp[0]=seq[0].kk+s[0]*seq[0].cc;
               for(int i=1;i<n;i++)
               {
                   int tp=0;
                   dp[i]=seq[i].cc*s[i]+seq[i].kk;
                   for(int j=0;j<i;j++)
                   {
                         tp=dp[j]+(s[i]-s[j])*seq[i].cc+seq[i].kk;
                         dp[i]=min(tp,dp[i]);
                   }
               }
               printf("%d\n",dp[n-1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37451344/article/details/80724792