POJ3150 Candies【差分约束】

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and cin order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input
2 2
1 2 5
2 1 4
Sample Output
5
Hint
32-bit signed integer type is capable of doing all arithmetic.

差分约束的经典题目

意思是A的糖果数比B少的个数不多于c,即B的糖果数 - A的糖果数<= c

就是把不等式关系转换成最短路里面的松弛条件

点很多 又是稀疏矩阵 所以用邻接表来存 head相当于头指针 next[i]记得是第i条边连接的下一条边的编号

用了spfa 如果用STL里的queue的话会T

要改用数组表示栈

还有就是 用cin cout也会T


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<map>
#include<cstring>
#include<queue>
#include<stack>
#define inf 0x3f3f3f3f

using namespace std;

int n, m, num_edge;
struct{
    int to, v, nnext;
}edge[150005];
int dis[30005], head[30005], Q[30005];
bool vis[30005];

void addedge(int a, int b, int c)
{
    edge[num_edge].to = b;
    edge[num_edge].v = c;
    edge[num_edge].nnext = head[a];
    head[a] = num_edge++;
}

void spfa(int sec)
{
    int top = 0;
    for(int v = 1; v <= n; v++){
        if(v == sec){
            Q[top++] = v;
            vis[v] = true;
            dis[v] = 0;
        }
        else{
            vis[v] = false;
            dis[v] = inf;
        }
    }
    while(top){
        int u = Q[--top];
        vis[u] = false;
        for(int i = head[u]; i != -1; i = edge[i].nnext){
            int v = edge[i].to;
            if(dis[v] > dis[u] + edge[i].v){
                dis[v] = dis[u] + edge[i].v;
                if(!vis[v]){
                    vis[v] = true;
                    Q[top++] = v;
                }
            }
        }
    }
}

int main()
{
    while(cin>>n>>m){
        num_edge = 0;
        for(int i = 1; i <= n; i++){
            head[i] = -1;
        }
        for(int i = 0; i < m; i++){
            int a, b, c;
            scanf("%d%d%d", &a, &b, &c);
            addedge(a, b, c);
        }
        spfa(1);
        printf("%d\n", dis[n]);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/wybooooooooo/article/details/79659211