C/C++[PAT A1025]Ranking

1025 PAT Ranking (25)(25 分)
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
把每个考场的排名合并到final rank
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
N:考场的数量,N <= 100;
K:每个考场人数,K <= 300
考生信息:考号13位数,分数,间隔空格

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
第一行:考生人数
第二行:考号 最终排名 考场号 考场排名
....
要求:final rank, local rank ,按照分数从高到低排序,分数相同按准考证从小到大排序
分数相同,排名相同.排名不连续,比如 1 2 2 2 5

Sample Input:

2  考场数
5  考场人数
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:

9  总考生数
考号 final_rank 考场号 local_rank
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

struct Student {
    char id[15];
    int sorce;
    int location_number;
    int local_rank;
}Stu[30010];

bool cmp(Student a, Student b) {
    if (a.sorce != b.sorce) return a.sorce > b.sorce;
    else return strcmp(a.id, b.id) < 0;
}

int main() {
    int n, k, num = 0;  //考场数,考场人数,考试人数
    cin>>n;
    for(int j = 1; j <= n; j++) {
        cin>>k;
        for(int i = 0; i < k; i++) {
            cin>>Stu[num].id >>Stu[num].sorce;
            Stu[num].location_number = j;
            num++;
        }
        sort(Stu + num -k, Stu + num, cmp ); //同一考场内排序
        Stu[num - k].local_rank = 1;
        for (int i = num - k + 1; i < num; i++) {
            if(Stu[i].sorce == Stu[i-1].sorce)
                Stu[i].local_rank = Stu[i-1].local_rank;
            else Stu[i].local_rank = i+1 - (num - k);
        }
    }
    cout<<num<<endl;
    sort(Stu, Stu+num, cmp);//对所有成绩排序
    int r = 1;
    for (int i = 0; i < num; i++) {
        if (i > 0 && Stu[i].sorce != Stu[i-1].sorce)
            r = i + 1;
        cout<<Stu[i].id<<' '<<r<<' '<<Stu[i].location_number<<' '<<Stu[i].local_rank<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u014281392/article/details/80767558