PAT A1025

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then Nranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

 题意:

pat考试,给出每个考场的考生信息,对他们进行排序

难点:

难点:

① 存储准考证号

用 字符数组存储,最后比较字典序就用 strcmp 函数进行比较,strcmp(str1, str2) < 0,即为字典序小的排在前面

② 对于每个考场数据的存储下标

设定一个整型变量 num,每输入完一个考场的考生(考生数为 k),就 num+=k;,然后每个考场当地排名也是从 num 开始到 num+k。

技巧:

① 第二次排名不需要存储,可以直接输出,就可以少1次 for 循环

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct Student{
	char id[13];
	int score;
	int lr; // 当地排名
	int kid; // 考场号
}stu[100000];
bool cmp(Student a, Student b){
	if(a.score != b.score)
		return a.score > b.score;
	else
		return strcmp(a.id, b.id) < 0;
}
int main(){
	int n;
	scanf("%d", &n);
	int num = 0;
	for(int i = 0; i < n; i++){
		int k;
		scanf("%d", &k);
		for(int j = num; j < k+num; j++){
			scanf("%s %d", stu[j].id, &stu[j].score);
			stu[j].kid = i+1;
		}
		sort(stu+num, stu+k+num, cmp);
		stu[num].lr = 1;
		for(int j = num+1; j < num+k; j++){
			if(stu[j].score == stu[j-1].score)
				stu[j].lr = stu[j-1].lr;
			else
				stu[j].lr = j+1-num;
		}		
		num = k + num;
	}
	sort(stu, stu+num, cmp);
	int r = 1;
	for(int i = 0; i < num; i++){
		if(i > 0 && stu[i].score != stu[i-1].score){
			r = i + 1;
		}
		printf("%s %d %d %d\n", stu[i].id, r, stu[i].kid, stu[i].lr);
		
	}	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/gsj9086/article/details/86655333