PAT 1039 Course List for Student

PAT 1039 Course List for Student


  • 时间限制: 1 Sec
  • 内存限制: 32 MB

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.


样例输入

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

分析与总结

  • 由于读入的数据量不定,可以用vector容器处理,看似不难;但是STL比较耗时(特别耗时 QAQ),因此要找合理的数据存储、查询结构
  • 由于学生姓名都是三个大写字母+1位数字的形式,因此可以用hash的方法减少字符串的操作量,节省时间
  • 自己的思路:以课程为中心,将学生对应课程;但这样一来,一是数据结构变复杂了(建立了Course结构体,储存课程编号学生姓名,其中学生是vector(string),程序运行相当耗时)
  • 别人的思路:以学生为中心,将课程对应学生
    建立vector stu[MAX],MAX是学生姓名最大哈希值个数,把课程编号加入到学生的vector中,这样查询时可以直接通过数组下标访问某学生信息,进而读取选课数选课编号的信息,且只需对所查询的学生选课信息进行排序

下面给出提交了12遍终于AC的代码~

#include<cstdio>
#include<vector>
#include<algorithm>
#define MAXX 26*26*26*10+1
using namespace std;

int hashFunc(char*,int);
vector<int> stu[MAXX];
int main()
{

    int n,k,num,course;
    char name[5];
    scanf("%d%d",&n,&k);

    //读取各门课的编号&选课同学,并将课程编号加入到相应同学的课程单中
    for(int i=0;i<k;i++){
        scanf("%d%d",&course,&num);
        for(int j=0;j<num;j++){
            scanf("%s",name);
            stu[hashFunc(name,4)].push_back(course);
        }
    }

    //读取查询的同学名单,并查询输出
    for(int i=0;i<n;i++){
        scanf("%s",name);
        printf("%s ",name);

        int hash=hashFunc(name,4);
        sort(stu[hash].begin(),stu[hash].end());
        printf("%d",stu[hash].size());

        for(vector<int>::iterator it = stu[hash].begin(); it != stu[hash].end(); it++){
            printf(" %d",*it);
        }
        if(i < n-1) printf("\n");
    }
    return 0;
}

int hashFunc(char *str, int len)
{
    int hash=0;
    for(int i=0;i<len-1;i++){
        hash = hash * 26 + (*(str+i) - 'A');
    }
    hash = hash * 10 + (*(str+len-1) - '0');
    return hash;
}

猜你喜欢

转载自blog.csdn.net/qq_29159273/article/details/54090887
今日推荐