PAT 1039 Course List for Student (模拟)

1039. Course List for Student (25)

时间限制
200 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
题目意思很简单,也很容易写出代码,刚开始直接简单写了个map<string, vector<int> > 直接做,最后一组case超时,继续审题,发现名字格式很标准,只有4位而且前三位为大写字母最后一位为数组,以前做过类似哈希的题目,因为字符创的各种操作都是相当费时的,如果能哈希为对应的一个唯一的整数就速度快很多,这样直接写过就可以了。代码如下:
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>

using namespace std;

const int maxx = 26 * 26 * 26 * 10 + 1;

int hashName(const char *name){
	return (name[0] - 'A') * 26 * 26 * 10\
		+ (name[1] - 'A') * 26 * 10\
		+ (name[2] - 'A') * 10\
		+ (name[3] - '0');
}

vector<int> course[maxx];

int main(){
	int n, k, cid, sn, hname;
	char name[5];
	vector<int>::iterator ib, ie;

	scanf("%d %d", &n, &k);
	for (int i = 0; i < k; ++i){
		scanf("%d %d", &cid, &sn);
		for (int j = 0; j < sn; ++j){
			scanf("%s", name);
			hname = hashName(name);
			course[hname].push_back(cid);
		}
	}

	for (int i = 0; i < n; ++i){
		scanf("%s", name);
		hname = hashName(name);

		printf("%s", name);
		printf(" %d", course[hname].size());

		sort(course[hname].begin(), course[hname].end());

		ib = course[hname].begin();
		ie = course[hname].end();

		for (; ib != ie; ++ib){
			printf(" %d", *ib);
		}
		printf("\n");
	}
	return 0;
}


最新博客地址,欢迎访问 凌风博客


发布了222 篇原创文章 · 获赞 44 · 访问量 63万+

猜你喜欢

转载自blog.csdn.net/IAccepted/article/details/39273311
今日推荐