PAT 甲 1039 Course List for Student

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N
​i
​​ (≤200) are given in a line. Then in the next line, N
​i
​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
题意:
输入N个学⽣,K⻔课,然后给出选择每⻔课的学⽣姓名,输入最后一行给出N个学生name
输出每个学生选课情况,每一行给出学生姓名 选课总数 选课id(递增)
思路:
将name转为int存储

	int id=0;
	for(int i=0;i<3;i++){
		id=26*id+(name[i]-'A');
	}
	id=id*10+(name[3]-'0');//最后一位 是数字

用vector存储每一位学生所选课情况,递增排序,最后根据输入最后一行查询学生姓名输出每一位选课id
C++代码:

#include<cstdio>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;
int nameId(char *name){
	int id=0;
	for(int i=0;i<3;i++){
		id=26*id+(name[i]-'A');
	}
	id=id*10+(name[3]-'0');//最后一位 是数字
	return id; 
}
vector<int> v[26*26*26*10+10];
int main(){
	int n,k;
	cin>>n>>k;
	char name[5];
	int id1,num,id=0;
	for(int i=0;i<k;i++){
		cin>>id1>>num;
		for(int j=0;j<num;j++){
			cin>>name;
			id=nameId(name);
			v[id].push_back(id1);
		}
	}
	for(int i=0;i<n;i++){
		cin>>name;
		id=nameId(name);
		sort(v[id].begin(),v[id].end());
		printf("%s %d",name,v[id].size());
		for(int j=0;j<v[id].size();j++){
			cout<<" "<<v[id][j];
		} 
		cout<<endl;
			}		
	return 0;
} 
发布了65 篇原创文章 · 获赞 5 · 访问量 4143

猜你喜欢

转载自blog.csdn.net/u014424618/article/details/105082634
今日推荐