PAT 甲 1047 Student List for Course

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
题意:
给出选课⼈数和课程数⽬,然后再给出每个⼈的选课情况,请针对每⻔课程输出选课⼈数
以及所有选该课的学⽣姓名,按照字典序~
思路:
用二维数组char[i][5]存储姓名,char[i]表示第i个姓名
用vector存储每门课的学生编号,course[i]存放所有选i的学生编号
对course[i]中的学生,利用sort按照姓名字典序从小到大排序
C++代码:

#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
#include<cstring>
using namespace std;
vector<int> course[2501];
char name[40001][5];
bool cmp(int a,int b){
	return strcmp(name[a],name[b])<0;
}
int main(){
	int n,k;
	cin>>n>>k;
	for(int i=0;i<n;i++){
		int count,tmp;
		scanf("%s %d",name[i],&count);
		for(int j=0;j<count;j++){
			cin>>tmp;
			course[tmp].push_back(i); 
		}
	}
	for(int i=1;i<=k;i++){
		cout<<i<<" "<<course[i].size()<<endl;
		sort(course[i].begin(),course[i].end(),cmp);
		for(int j=0;j<course[i].size();j++){
			printf("%s\n",name[course[i][j]]);
		}
	} 
}
发布了72 篇原创文章 · 获赞 5 · 访问量 4439

猜你喜欢

转载自blog.csdn.net/u014424618/article/details/105107407
今日推荐