PAT 1047 Student List for Course (25 分)

1047 Student List for Course (25 分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.


Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.


Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1




解析

我竟然遇到了用cin,cout超时,用scanf,printf不超时的题。就是这题。我以后做PAT再也不用cin,cout了。


建立一个课程->学生的表即可。由于课程编号是从1-K,所以可以直接用vector当表。

#include<vector>
#include<string>
#include<algorithm>
#include<cstdio>
#include<iostream>
using namespace std;
bool cmp(const string& a,const string& b) {
	return a < b;
}
int main()
{
	int N, K;
	scanf("%d %d", &N, &K);
	vector<vector<string>> student(K+1);
	string name;
	int time, course;
	for (int i = 0; i < N; i++) {
		cin >> name;
		scanf("%d", &time);
		for (int j = 0; j < time; j++) {
			scanf("%d", &course);
			student[course].push_back(name);
		}
	}
	for (int i = 0; i < K; i++) {
		sort(student[i + 1].begin(), student[i + 1].end(), cmp);
		printf("%d %d\n", i + 1, student[i+1].size());
		for (auto x : student[i + 1])
			printf("%s\n", x.c_str());
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/83998478