1047 Student List for Course (25 分)

1047 Student List for Course (25 分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

分析:

本题结题思路较为常规,属于简单题,但是最后一个测试点容易运行超时或者运行超限一般处理运行超时的方式优先会将程序中所有的输入和输出换成C语言对应的输入和输出,scanf/printf,这个会比cin/cout耗时少,但是依然不奏效源代码1超时测试点依然没通过。参考博客1修改源代码1。解法较简单,此处不赘述,本分析旨在测试点超时的问题,从源代码2中我们似乎可以分析出程序处理int类型的时间要比string或者字符数组(e.g. char * name])的时间要长。

小结:运行超时问题
1.采用scanf、printf输入输出;
2.以时间换空间,降低时间复杂度,特别地,在查询操作中,时间复杂度可以由O(N)降低为O(1);
3.处理字符串比处理整型数要耗时,一般通过hash散列将字符串映射成整型数,通过直接处理整型数间接处理字符串,这条结论不知道成不成立,但是在此题奏效。

源代码2

#include<iostream>
#include <vector>
#include <algorithm>
#include <cstring>
using namespace std;
char name[40010][5];
bool cmp(int a,int b){
	if(strcmp(name[a],name[b])<0) return true;
	else return false;
}
int main(){
	int n,k;
	scanf("%d %d",&n,&k);
	vector<vector<int> > v(n+1);
	for(int i=0;i<n;i++){
		scanf("%s",name[i]);				
		int cnt;
		scanf("%d",&cnt);
		for(int j=0;j<cnt;j++){
			int k;
			scanf("%d",&k);
			v[k].push_back(i);
		}
	}
	for(int i=1;i<=k;i++){
		printf("%d %d\n",i,(int)v[i].size());
		sort(v[i].begin(),v[i].end(),cmp);
		for(auto it : v[i]) {
			printf("%s\n",name[it]);
		}
	}
	return 0;
} 

源代码1

#include<iostream>
#include <vector>
#include <set>
#include <cmath>
using namespace std;
int main(){
	int n,k;
	scanf("%d %d",&n,&k);
	vector<set<int> > v(n+1);
	for(int i=0;i<n;i++){
		char name[5];
		scanf("%s",name);
		int name_int=0;
		for(int i=0;i<=3;i++){
			name_int = name_int*100+name[i];
		}					
		int cnt;
		scanf("%d",&cnt);
		for(int j=0;j<cnt;j++){
			int k;
			scanf("%d",&k);
			v[k].insert(name_int);
		}
	}
	for(int i=1;i<=k;i++){
		printf("%d %d\n",i,(int)v[i].size());
		for(auto it : v[i]) {
			char name[5];
			for(int i=0;i<=3;i++){
				int tmp=(int)pow(100,3-i);
				name[i]=it/tmp;
				it%=tmp;
			}
			printf("%s\n",name);
		}
	}
	return 0;
} 

  1. https://www.liuchuo.net/archives/2147 ↩︎

猜你喜欢

转载自blog.csdn.net/whutshiliu/article/details/82975591