A1047 Student List for Course (25 分)

本题为 A1039 Course List for Student (25 分)反过来的题

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题意:

给出选课人数和课程数目,再给出每个人的选课情况。输出每门课程的选课学生(按照字典序排列)。

思路:

  1. 采用 char name[N][5] 二维char数组来存放姓名,name[i] 表示输入的第 i 个姓名
  2. 采用 vector 数组 course[] 存放每门课的学生编号(即为 name[i] 数组中的 i ),其中 course[j] 存放所有选择第 j 门课的学生编号
  3. 按照字典序排序为 strcmp(name[a], name[b]) < 0;

注意:

  1. 使用 string 时最后一组数据容易超时。像这种范围很大的情况,一般最好使用 char 数组来存放数据
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 40010;
const int maxc = 2510;

char name[maxn][5];
vector<int> course[maxc];

bool cmp(int a, int b){
  return strcmp(name[a], name[b]) < 0;
}

int main(){
  int n, k, c, courseID;
  scanf("%d %d", &n, &k);
  for(int i = 0; i < n; i++){
    scanf("%s %d", name[i], &c);
    for(int j = 0; j < c; j++){
      scanf("%d", &courseID);
      course[courseID].push_back(i);
    }
  }
  for(int i = 1; i <= k; i++){
    printf("%d %d\n", i, course[i].size());
    sort(course[i].begin(), course[i].end(), cmp);
    for(int j = 0; j < course[i].size(); j++){
      printf("%s\n", name[course[i][j]]);
    }
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/87606426