PAT甲组 1047. Student List for Course (25)

1047. Student List for Course (25)

时间限制
400 ms
内存限制
64000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1


题意:N个大佬的选课情况,K个课程(1~K的课程编号),接下来N行每行是一个大佬的选课,名字后面的C是选课的数量,最后要按课程编号升序的顺序输出每个课程选择的人数,选择的人的名单(字典序排序)。

思路:用vector来存放选每个课程的同学的名字,二维字符串数组(string超时)存放同学的名字。ps:最后一组数据量贼大,一开始用cin和cout超时了,要用scanf和printf哦!

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
#include<map>
#include<vector>
#include<set>
using namespace std;
const int maxv = 44444;
const int maxp = 2555;

char id[maxv][6];//学生名字
vector<int>co[maxp];//存放选某课程的学生

int N,K,C;

bool cmp(int x,int y)
{
	return strcmp(id[x],id[y])<0;//看了下算法笔记上是用这种字符串下标代替字符串本身移动排序的方法,比直接比较字符串快,太强了
}

int main()
{
	scanf("%d %d",&N,&K);
	for(int i=0;i<N;i++)
	{
		scanf("%s %d",id[i],&C);
		for(int j=0;j<C;j++)
		{
			int temp;
			scanf("%d",&temp);
			co[temp].push_back(i);
		}
	}
	for(int i=1;i<=K;i++)
	{
		printf("%d %d\n",i,co[i].size());
		sort(co[i].begin(),co[i].end(),cmp);
		for(int j=0;j<co[i].size();j++)
			printf("%s\n",id[co[i][j]]);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_39396954/article/details/79245214