HDU1233 + 最小生成树prim

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。 
Input测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。 
当N为0时,输入结束,该用例不被处理。 
Output对每个测试用例,在1行里输出最小的公路总长度。 
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
Sample Output
3
5


        
  
Huge input, scanf is recommended.
Hint

Hint




#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int maxn = 100 + 10;
int cost[maxn][maxn];//表示公路的权值
int mincost[maxn];
bool used[maxn];
int V;//顶点数
int prim() {
    for (int i = 1; i <= V; i++) {
        mincost[i] = INF;
        used[i] = false;
    }
    mincost[1] = 0;
    int res = 0;
    while (true) {
        int u = -1;
        //从不属于最小生成树集合X的顶点中选取从当前已经生成的树X到其权值最小的顶点
        for (int v = 1; v <= V; v++) {
            if (!used[v] && (u == -1 || mincost[v] < mincost[u])) u = v;
        }
        if (u == -1) break;
        used[u] = true;//把顶点加入到X
        res += mincost[u];//把边的长度加入到结果里

        //更新当前u的领边的情况
        for (int v = 1; v <= V; v++) {
            mincost[v] = min(mincost[v], cost[u][v]);
        }
    }
    return res;
}
int main() {
    while(scanf("%d", &V) && V) {
        memset(cost, 0, sizeof(cost));
        memset(mincost, 0, sizeof(mincost));
        memset(used, 0, sizeof(used));

        for (int i = 0; i < V*(V - 1)/2; i++) {
            int a, b, c;
            scanf("%d %d %d", &a, &b, &c);
            cost[a][b] = cost[b][a] = c;
        }
        printf("%d\n", prim());
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_34649947/article/details/80407918
今日推荐