【次小生成树/Prim】Qin Shi Huang's National Road System HDU4081

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
Input The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location. Output For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point. Sample Input
2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40
Sample Output
65.00
70.00



#include <bits/stdc++.h>
using namespace std;

const int mn = 1010;
const int mm = mn * mn;
const int inf = 0x7fffffff;

int x[mn], y[mn], p[mn];
double cost[mn][mn];
bool used[mn];
bool is[mn][mn];
double dis[mn];
int par[mn];
double path[mn][mn];

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		int n;
		scanf("%d", &n);
		for (int i = 1; i <= n; i++)
			scanf("%d %d %d", &x[i], &y[i], &p[i]);

		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= n; j++)  // i, j间距离
				cost[i][j] = sqrt((x[i] - x[j]) * (x[i] - x[j]) + (y[i] - y[j]) * (y[i] - y[j]));

		memset(is, 0, sizeof is);
		memset(used, 0, sizeof used);  // 都不在树上
		memset(path, 0, sizeof path);  // 任意两点间最长路 = 0

		// 从点1开始建树
		for (int i = 1; i <= n; i++)
		{
			par[i] = i;
			dis[i] = cost[1][i];    // 离树的最短距离
		}
		dis[1] = 0;
		used[1] = 1;

		double sum = 0;  // 树的总边长
		while (1)  // Prim 算法
		{
			int t = -1;
			for (int i = 1; i <= n; i++)
				if (!used[i] && (t == -1 || dis[i] < dis[t]))
					t = i;
			if (t == -1)
				break;

			sum += dis[t];
			used[t] = 1;
			is[par[t]][t] = is[t][par[t]] = 1;
			for (int i = 1; i <= n; i++)
			{
				if (used[i] && i != t)
				{
					path[t][i] = path[i][t] = max(path[i][par[t]], dis[t]);  // 新吸纳边 par[t] —— [t]
				}
				else if (!used[i])  // 不在树上
				{
					if (dis[i] > cost[t][i])
					{
						dis[i] = cost[t][i];  // 更新到树的最短距离
						par[i] = t;
					}
				}
			}
		}

		double ans = 0;
		for (int i = 1; i <= n; i++)
		{
			for (int j = i + 1; j <= n; j++)
			{
				double t = 0;
				if (is[i][j])  // 魔法边在最小生成树上
					t = (p[i] + p[j]) / (sum - cost[i][j]);
				else   // 不在
					t = (p[i] + p[j]) / (sum - path[i][j]);

				ans = (ans > t) ? ans : t;
			}
		}
		printf("%.2f\n", ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/80783563