【HDU】 4081 次小生成树

版权声明:抱最大的希望,为最大的努力,做最坏的打算。 https://blog.csdn.net/qq_37748451/article/details/86497391
Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.


Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 

Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
 

Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 

Sample Input
2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40
 

Sample Output
65.00
70.00
 

Source
2011 Asia Beijing Regional Contest

题意:

给出一些点的坐标代表一些城市并给出一个值代表这个城市的人口,总共有n-1条道路,
其中有一条道路是没有权值的,
这条道路所连接的两城市的人口数和为A然后其余n-2条道路的权值之和为B,
问A/B的最大值
 

刘汝佳 蓝皮书 P345

先求出最小生成树,在枚举边u-v后删除最小生成树中的u和v上唯一路径上的最大权

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define PI acos(-1.0)
#define E 1e-6
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define maxn 1010
using namespace std;
#define ll long long int
int n,m;
double sum,ans;
double dist[maxn];
double city[maxn][maxn];
double maxd[maxn][maxn];
bool vis[maxn];
int pre[maxn];
vector<int>v;
struct Node
{
    int x;
    int y;
    int p;
}pou[maxn];
double distan(int k1,int k2)
{
    double xx,yy;
    xx=pou[k1].x-pou[k2].x;
    yy=pou[k1].y-pou[k2].y;
    return sqrt(xx*xx+yy*yy);
}
void prim()
{
    int i,j,k,mi;
    int now=1;
    sum=0;
    vis[1]=1;
    dist[1]=0;
    v.push_back(1);
    for(i=1;i<n;i++)
    {
        for(j=1;j<=n;j++)
        {
            if(vis[j]==0&&city[now][j]<dist[j])
            {
                pre[j]=now;
                dist[j]=city[now][j];
            }
        }
        mi=INF;
        for(j=1;j<=n;j++)
        {
            if(vis[j]==0&&dist[j]<mi)
            {
                mi=dist[j];
                k=j;
            }
        }
        sum+=dist[k];
        now=k;
        vis[k]=1;
        for(j=0;j<v.size();j++)
        {
            maxd[v[j]][k]=maxd[k][v[j]]=max(maxd[v[j]][pre[k]],dist[k]);
        }//路径上最大边的值
        v.push_back(k);
    }
}


int main()
{
    int i,j,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(vis,0,sizeof(vis));
        memset(maxd,0,sizeof(maxd));
        v.clear();
        for(i=1;i<=n;i++)
        {
        dist[i]=INF;
        for(j=1;j<=n;j++)
            city[i][j]=INF;
        }
        for(i=1;i<=n;i++)
            scanf("%d%d%d",&pou[i].x,&pou[i].y,&pou[i].p);
        for(i=1;i<=n;i++)
          for(j=i+1;j<=n;j++)
            city[i][j]=city[j][i]=distan(i,j);
        prim();
        double a,b;
        ans=0;
        for(i=1;i<=n;i++)
          for(j=i+1;j<=n;j++)
          {
            a=pou[i].p+pou[j].p;
            b=sum-maxd[i][j];
            if(ans<a/b)
            ans=a/b;
          }
        printf("%.2f\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37748451/article/details/86497391