POJ3630 HDU1671 ZOJ2876 UVA11362 Phone List【字典树】

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 33225   Accepted: 9609

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

Source


问题链接POJ3630 HDU1671 ZOJ2876 UVA11362 Phone List

问题描述

  输入若干数字组成的字符串集合,判断这些字符串是否一致,若其中某个字符串是为另外一个字符串的前缀则不是一致的。

问题分析

  该问题用构建字典树的方法来解决。构造一个字典树进行判断即可。

程序说明:(略)

参考链接:(略)

题记(略)


AC的C++语言程序如下:

/* POJ3630 HDU1671 ZOJ2876 UVA11362 Phone List */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 10000;
const int LEN = 10;
const int SIZE = 10;
const char SCHAR = '0';

struct Trie {
    int acnt;   // access count
    int ccnt;   // child number
    int childs[SIZE];
    void init()
    {
        acnt = 1;
        ccnt = 0;
        memset(childs, 0, sizeof(childs));
    }
} trie[N * LEN];
int ncnt;   // Trie Node count
char s[LEN + 1]; // Input

bool insert(char s[])
{
    int p = 0;
    for(int i = 0; s[i]; i++) {
        int k = s[i] - SCHAR;
        int child = trie[p].childs[k];
        if(child) {
            trie[child].acnt++;
            p = child;
        } else {
            if(i > 0 && trie[p].acnt > 1 && trie[p].ccnt == 0)
                return false;
            trie[++ncnt].init();
            trie[p].childs[k] = ncnt;
            trie[p].ccnt++;
            p = ncnt;
        }
    }
    return trie[p].ccnt == 0;
}

int query(char s[])
{
    int p = 0;
    for (int i = 0; s[i]; i++) {
        int k = s[i] - SCHAR;
        int child = trie[p].childs[k];
        if (child == 0)
            return 0;
        else
            p = child;
    }
    return trie[p].ccnt;
}

int main()
{
    int t, n;
    scanf("%d", &t);
    while(t--) {
        bool flag = true;
        ncnt = 0;
        trie[ncnt].init();

        scanf("%d", &n);
        for(int i = 1; i <= n; i++) {
            scanf("%s", s);
            if(flag)
                if(!insert(s))
                    flag = false;
        }

        printf("%s\n", flag ? "YES" : "NO");
    }

    return 0;
}






猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80948189