HDU1671 Phone List(vector+string水过)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42391248/article/details/81708355

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25390    Accepted Submission(s): 8460

 

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题意:给你n串数字号码,如果某两个数字存在子集关系,就输出NO,否则输出YES

题解:用字符串数组存号码,排序,判断如果相邻的两个号码串存在字串关系,就输出NO,否则输出YES。

具体代码如下:

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <cstdio>
using namespace std;
int main()
{
    vector<string> v;
    char ch[10];
    string s;
    int n;
    cin>>n;
    int i,j;
    while(cin>>n)
    {
        v.clear();
        for(i=0;i<n;i++)
        {
            scanf("%s",&ch);
            s=ch;
            v.push_back(s);
        }
        sort(v.begin(),v.end());
        for(i=0;i<n-1;i++)
        {
            if(v[i+1].find(v[i])==0)
            {
                cout<<"NO"<<endl;
                goto RL;
            }
        }
        cout<<"YES"<<endl;
        RL:continue;
    }
    return 0;
}
扫描二维码关注公众号,回复: 2964164 查看本文章

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/81708355