HDU-1671/nanyang163/Phone List

Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

思路:巧妙利用sort的字典序解决问题

代码如下:

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
 string str[100005],str2;
 char p[15];
 int t,n,flag;
 scanf("%d",&t);
 while(t--)
 {
  scanf("%d",&n);
  flag=1;
  for(int i=0;i<n;i++){
   scanf("%s",p);
   str[i]=p;
  }
  sort(str,str+n);
  for(int i=0;i<n;i++){
   if(str[i]<str[i+1]){
    if(str[i+1].substr(0,str[i].size())==str[i]){
     flag=0;
     break;
    }
   }
  }   
  if(!flag) printf("NO\n");
  else printf("YES\n");
 }
}


猜你喜欢

转载自blog.csdn.net/dadaguai001/article/details/81011324