poj3630 Phone List

Phone List

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 34399   Accepted: 9897

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

然后这个题的大意呢就是给你T组字符串集合,让你判断在每一个集合中是否有一个字符串是另一个的前缀

是的话就输出NO!!!不是的话就输出YES!!!这个设定可坑人了!!!

以下就是我在小蓝书的帮助下打出来的代码(为自己鼓鼓掌)

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int T,n,tot;
const int N = 1e5 + 3;
bool bo[N];
int ch[N][10];
char s[12];
void clear()
{
	memset(ch,0,sizeof(ch));
	memset(bo,false,sizeof(bo));
}
bool insert(char * s)
{
	int l = strlen(s);
	int u = 1;
	bool flag = false; 
	for(int i = 0;i < l;i++)
	{
		int c = s[i] - '0';
		if(ch[u][c] == 0) ch[u][c] = ++tot;
		else if(i == l - 1)flag = true;//如果它是别人的前缀那么条件成立 
		u = ch[u][c];
		if(bo[u] == true)flag = true;//如果它途经了别人的终点那么条件也成立 
		
	}
	bo[u] = true;
	return flag;
}
int main()
{
	scanf("%d",&T);
	while(T--)//输入T组数据 
	{
		scanf("%d",&n);
		bool ans = false;
		tot = 1;
		clear();
		for(int i = 1;i <= n;i++)
		{
			scanf("%s",s);
			if(insert(s) == true) ans = true;			
		} 
		if(ans == true)printf("NO\n");
		else printf("YES\n");
	}
	return 0;
}

哇,已经九点半多了,我要去吃宵夜了

猜你喜欢

转载自blog.csdn.net/qq_42914224/article/details/82355385