POJ 3630 Phone List(Trie)

原题链接

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题目大意

在n(n<=10000)个字符串中,问是否任一字符串都不是其它串的前缀。

解题思路

字典树的裸题,在加串的过程中如果经过了叶节点或者加完串发现最后一步不是新建的,那就判断NO。

AC代码

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cctype>
#include<algorithm>
#include<cmath>
#include<vector>
#include<string>
#include<queue>
#include<list>
#include<stack>
#include<set>
#include<map>
#define ll long long
#define ull unsigned long long
#define db double
//#define rep(i,n) for(int i = 0;i < n; i++)
//#define rep(i,n) for(int i = 0;i < n; i++)
#define rep(i,a,b) for (int i=(a),_ed=(b);i<=_ed;i++)
//#define rep(i,a,b) for(int i=(a);i<(b);++i)
#define fil(a,b) memset((a),(b),sizeof(a))
#define cl(a) fil(a,0)
#define pb push_back
#define mp make_pair
#define exp 2.7182818
#define PI 3.141592653589793238462643383279502884
#define inf 0x3f3f3f3f
#define fi first
#define se second
#define eps 1e-6
#define MOD 1000000007ll
using namespace std;
const int CHAR=10,MAXN=100000;
int fflag;
char str[20];
struct Trie
{
    int tot,root,child[MAXN][CHAR];
    bool flag[MAXN]; 
    Trie()
    {
        memset(child[1],0,sizeof(child[1]));
        flag[1]=true;
        root=tot=1;
    }
    void Insert(const char *str)
    {
        int sign=0;
        int *cur=&root;
        for(const char*p=str;*p;p++)
        {
            cur=&child[*cur][*p-'0'];

            if(flag[*cur]) fflag=0;

            if(*cur==0)
            {
                *cur=++tot;
                memset(child[tot],0,sizeof(child[tot]));
                flag[tot]=false;
                if(!(*(p+1))) sign=1;
            }
        }
        if(!sign) fflag=0;
        flag[*cur]=true;
    }

    bool Query(const char *str)
    {
        int *cur=&root;
        for(const char *p=str;*p&&*cur;p++)
            cur=&child[*cur][*p-'0'];
        return (*cur)&&flag[*cur]; 
    }

}tree;

int main(void) 
{
    //freopen("input.txt","r",stdin);
    //freopen("output.txt","w",stdout);
    int t,n;
    cin>>t;
    while(t--)
    {
        //Trie tree;
        memset(tree.child[1],0,sizeof(tree.child[1]));
        tree.flag[1]=true;
        tree.root=tree.tot=1;

        scanf("%d",&n);
        fflag=1;
        for(int i=1;i<=n;++i)
        {
            scanf("%s",str);
            tree.Insert(str);
        }
        if(fflag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xj949967574/article/details/77452615