upc Talent Show(01分数规划 背包)

Talent Show

时间限制: 1 Sec  内存限制: 128 MB
提交: 162  解决: 58
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Farmer John is bringing his N cows, conveniently numbered 1…N, to the county fair, to compete in the annual bovine talent show! His ith cow has a weight wiwi and talent level ti, both integers.
Upon arrival, Farmer John is quite surprised by the new rules for this year's talent show:

(i) A group of cows of total weight at least W must be entered into the show (in order to ensure strong teams of cows are competing, not just strong individuals), and

(ii) The group with the largest ratio of total talent to total weight shall win.

FJ observes that all of his cows together have weight at least W, so he should be able to enter a team satisfying (i). Help him determine the optimal ratio of talent to weight he can achieve for any such team.

输入

The first line of input contains N (1≤N≤250) and W (1≤W≤1000). The next N lines each describe a cow using two integers wi (1≤wi≤106) and ti (1≤ti≤103).

输出

Please determine the largest possible ratio of total talent over total weight Farmer John can achieve using a group of cows of total weight at least W. If your answer is A, please print out the floor of 1000A in order to keep the output integer-valued (the floor operation discards any fractional part by rounding down to an integer, if the number in question is not already an integer).

样例输入

3 15
20 21
10 11
30 31

样例输出

1066

提示

In this example, the best talent-to-weight ratio overall would be to use just the single cow with talent 11 and weight 10, but since we need at least 15 units of weight, the optimal solution ends up being to use this cow plus the cow with talent 21 and weight 20. This gives a talent-to-weight ratio of (11+21)/(10+20) = 32/30 = 1.0666666..., which when multiplied by 1000 and floored gives 1066.

来源/分类

USACO 2018 US Open Contest, Gold 

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<vector>
#include<cmath>
#include<algorithm>
using namespace std;
#define LL long long
#define inf 0x3f3f3f3f
#define lowb(x) x&-x
#define rep(i,j,k) for(int i=j;i<=k;i++)
#define per(i,j,k) for(int i=j;i>=k;i--)
#define N 10005
#define esp 1e-6
LL w[300];
LL t[300];

LL ww;
LL f[1000005];
int n;

bool check(LL m)
{
    memset(f,-inf,sizeof(f));
    f[0]=0;
    for(int i=1;i<=n;i++)
    {
        for(int j=ww;j>0;j--)
        {
            int jj=j-w[i];
            jj=max(jj,0);//w[j]可能大于j
            f[j]=max(f[j],f[jj]+t[i]-m*w[i]);
        }
    }
    return f[ww]>=0;
}

void solve()
{
    LL l=0;
    LL r=1e6;
    while(l<=r)
    {
        LL m=(r+l)/2;
        check(m)? l=m+1: r=m-1;
        //cout<<m<<endl;
    }
    cout<<r<<endl;
}
int main()
{

    while(cin>>n>>ww)
    {
        rep(i,1,n)
        {
            cin>>w[i]>>t[i];
            t[i]*=1000;
        }
        solve();
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_40894017/article/details/81194463