HUD 6308 Time Zone(水)

Time Zone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 677    Accepted Submission(s): 227

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤9).

Output

For each test, output the time in the format of hh:mm (24-hour clock).

Sample Input

3

11 11 UTC+8

11 12 UTC+9

11 23 UTC+0

Sample Output

11:11

12:12

03:23

Source

2018 Multi-University Training Contest 1

#include <iostream>
#include <cstdio>
#include <cmath>
#define LL long long
using namespace std;
int around(float x)
{
    int cnt = 1;
    if(x<0) cnt = -cnt;
    if(abs(x)-abs((int)x) > 0.5)
        return (int)x+cnt;
    return (int)x;
}
int main()
{
    int t, m, h;
    float x;
    char ch;
    string str;
    scanf("%d", &t);
    while(t --)
    {
        scanf("%d%d", &h, &m);
        getchar();
        scanf("UTC%c%f", &ch, &x);
        if(ch=='-') x=-x;
        x-=8;
        //printf("%d %f %f\n", m, (x-(int)x), (x-(int)x)*60);
        m+=around((x-(int)x)*60);
        h+=(int)x;

        if(m>=60){m-=60;h++;}
        if(m<0){m+=60;h--;}
        if(h>=24){h-=24;}
        if(h<0) {h+=24;}

        if(h<10) printf("0");
        printf("%d:", h);
        if(m<10) printf("0");
        printf("%d\n", m);
    }
}

猜你喜欢

转载自blog.csdn.net/a_thinking_reed_/article/details/81177999
HUD