HDU-6308 Time Zone(时区转换)

Time Zone
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2866 Accepted Submission(s): 908

Problem Description
Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of “UTC+X”, “UTC-X”, “UTC+X.Y”, or “UTC-X.Y” (0≤X,X.Y≤14,0≤Y≤9).

Output
For each test, output the time in the format of hh:mm (24-hour clock).

Sample Input
3
11 11 UTC+8
11 12 UTC+9
11 23 UTC+0

Sample Output
11:11
12:12
03:23

题意:给出北京时间,给出要变化的时区,将输出当地时间。
将小时直接转换成分钟,注意针对北京+8来调整相差时间的正负,还有处理小数时区,直接将小时转换成分钟后0.1小时即6分钟

#include<bits/stdc++.h>
using namespace std;
int t,a,b,x,y;
int main()
{
    char tim[10];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&b);
        scanf("%s",tim);
        x=0,y=0;
        for(int i=4;i<strlen(tim);i++)
        {
            if(tim[i]=='.')
            {
                y=tim[i+1]-'0';
                break;
            }
            x*=10;
            x+=tim[i]-'0';
        }
        x=x*60+y*6;
        if(tim[3]=='-')x=-x;
        x-=480;
        a=a*60+b;
        a=(a+x+1440)%1440;
        printf("%02d:%02d\n",a/60,a%60);
    }
}

猜你喜欢

转载自blog.csdn.net/kuronekonano/article/details/81353195
今日推荐