K - Time Zone HDU - 6308

 2018 Multi-University Training Contest 1

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem. 
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone ss. 

Input

There are multiple test cases. The first line of input contains an integer TT (1≤T≤1061≤T≤106), indicating the number of test cases. For each test case: 
The first line contains two integers aa, bb (0≤a≤23,0≤b≤590≤a≤23,0≤b≤59) and a string ss in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤90≤X,X.Y≤14,0≤Y≤9).

Output

For each test, output the time in the format of hh:mmhh:mm (24-hour clock). 

Sample Input

3
11 11 UTC+8
11 12 UTC+9
11 23 UTC+0

Sample Output

11:11
12:12
03:23

写的很乱  进攻参考……


#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int T;
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        int a,b;
        char s[10];
        scanf("%d%d%s",&a,&b,s);
        int x,y;
        y=0;
        x=0;
        int sign1 =0,sign2=0;
        int i=0;
        for(; i<strlen(s); i++)
        {
            if(s[i]=='.')
            {
                sign2=1;
                break;
            }
            if(sign1==1)
                x=x*10+s[i]-'0';
            if(s[i]=='+'||s[i]=='-')
                sign1=1;
        }
        if(sign2==1)
        {
            y=s[i+1]-'0';
        }
        int p;
        if(s[3]=='+')
            p=x-8;
        else
            p=-(x+8);
        int hh,mm;
        hh=a+p;
        int q=y*6;
        if(s[3]=='+')
            mm=b+q;
        else
            mm=b-q;
        if(mm>=60)
        {
            mm=mm-60;
            hh++;
        }
        if(mm<0)
        {
            mm=mm+60;
            hh--;
        }
        if(hh>=24)
            hh=hh-24;
        if(hh<0)
            hh=hh+24;
            if(hh<10)
                printf("0");
        printf("%d:",hh);
        if(mm<10)
            printf("0");
        printf("%d\n",mm);
    }
    return 0;
}
发布了19 篇原创文章 · 获赞 3 · 访问量 1393

猜你喜欢

转载自blog.csdn.net/xuanhuangwendao/article/details/81214507