PAT 1124 Raffle for Weibo Followers(20 分)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

思路:1.得过奖的要跳过 2.每隔s个人

程序: 

#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
#include <algorithm>
#include <map>
using namespace std;
int main()
{
  int m,n,s;
  scanf("%d%d%d",&m,&n,&s);
  vector<string> follower;
  map<string,int> mm;
  int k = 0;
  for(int i = 0; i < m; i++)
  {
    string name;
    cin>>name;
    mm[name] = 0;
    follower.push_back(name);
  }
  if(s > m)
  {
    printf("Keep going...\n");
    return 0;
  }
  else
  {
    for(int i = s - 1; i < follower.size(); i += n)
    {
      string name = follower[i];
      if(mm[name] == 0)
      {
        cout<<name<<endl;
        mm[name] = 1;
      }
      else
      {
        while(mm[follower[i]] == 1 && i < follower.size())
        {
          i++;  
        }
        if(i < follower.size())
        {
          mm[follower[i]] = 1;
          cout<<follower[i]<<endl;
        }
      }
    }
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/Hickey_Chen/article/details/81259817
今日推荐