1124 Raffle for Weibo Followers

1124 Raffle for Weibo Followers
John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:
For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going… instead.

Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain
Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain
Sample Input 2:
2 3 5
Imgonnawin!
PickMe
Sample Output 2:
Keep going…
参考代码:

#include<iostream>
#include<string>
#include<vector>
using namespace std;

int main()
{
	int M, N, S, count = 0, i, k;
	string s;
	vector<string>v;
	vector<string>v1;
	cin >> M >> N >> S;
	for (i = 1; i <= M; i++) { /*M次转发*/
		cin >> s;
		v.push_back(s);
	}
	k = N;
	for (i = S - 1; i<v.size(); i++){
		if (k == N){
			for (auto it = v1.begin(); it != v1.end(); it++){
				if (v[i] == *it){
					k--; break;
				}
			}
			if (k == N){
				cout << v[i] << endl;
				v1.push_back(v[i]);
				k = 0;
				count++;
			}
		}
		k++;
	}
	if (count == 0)
		cout << "Keep going...";

	return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/82943305
今日推荐