1124 Raffle for Weibo Followers(20 分)(PAT甲级真题)

大佬们大部分都用的map,我只用了string,比map麻烦一点。作为另一种思路,仅供参考。

题目如下:

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

参考代码如下:

#include <iostream>
#include <cstring>
#include <string>
#include <cstdlib>
using namespace std;
int main()
{
    int n, k, st;
    string s1[1010], s2;         //s2用来储存出现过的id
    cin >> n >> k >> st;
    for (int i = 1; i <= n; i++)
        cin >> s1[i];
    if (st > n)
        cout << "Keep going...";         //第一个中奖者st比总人数n大
    else {
        cout << s1[st] << endl;
        s2 = s1[st];                          //将第一个中奖者存到s2
        for (int i = st + k; i <= n; i += k) {
            if (s2.find(s1[i]) == string::npos) {             //如果s1[i]没出现过
                cout << s1[i] << endl;
                s2 = s2 + " " + s1[i];                             //将s1[i]添加到s2后面,记得中间加空格
            }
            else {
                while (s2.find(s1[i]) != string::npos && i <= n) {               //直到找到未出现的s1[i]
                    i++;
                }
                if (i <= n) {                                       //如果最后i没超出范围
                    cout << s1[i] << endl;
                    s2 = s2 + " " + s1[i];                    //将s1[i]添加到s2后面,记得中间加空格
                }
            }
        }
    }
    system("pause");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zclimou/article/details/81953455