Milk Patterns

Problem Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: <i>N</i> and <i>K</i> <br>Lines 2..<i>N</i>+1: <i>N</i> integers, one per line, the quality of the milk on day <i>i</i> appears on the <i>i</i>th line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least <i>K</i> times

Sample Input

 

8 2 1 2 3 2 3 2 3 1

Sample Output

 

4

后缀和加二分

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 100005
using namespace std;
int key[maxn];
int sa[maxn];
int t1[maxn];
int t2[maxn];
int c[maxn];
int height[maxn];
int rank[maxn];
void buildsa(int*s,int n,int m)
{
    int i;
    int *x=t1;
    int *y=t2;
    for(i=0;i<m;i++)
    c[i]=0;
    for(i=0;i<n;i++)
    c[x[i]=s[i]]++;
    for(i=1;i<m;i++)
    c[i]+=c[i-1];
    for(i=n-1;i>=0;i--)
    sa[--c[x[i]]]=i;
     for(int k=1;k<=n;k*=2)
    {
        int p=0;
        for(i=n-k;i<n;i++)
        y[p++]=i;
        for(i=0;i<n;i++)
        if(sa[i]>=k)
        y[p++]=sa[i]-k;
        for(i=0;i<m;i++)
        c[i]=0;
        for(i=0;i<n;i++)
        c[x[y[i]]]++;
        for(i=1;i<m;i++)
        c[i]+=c[i-1];
        for(i=n-1;i>=0;i--)
        sa[--c[x[y[i]]]]=y[i];
        swap(x,y);
        p=1;
        x[sa[0]]=0;
        for(int i=1;i<n;i++)
        x[sa[i]]=y[sa[i-1]]==y[sa[i]]&&y[sa[i-1]+k]==y[sa[i]+k]?p-1:p++;
        if(p>=n)
        break;
        m=p;
    }
}
void getheight(int*s,int n)
{
    int i,j,k=0;
    for(i=0;i<n;i++)
    rank[sa[i]]=i;
    for(int i=0;i<n;i++)
    {
        if(k)
        k--;
        int j=sa[rank[i]-1];
        while(s[i+k]==s[j+k])
        k++;
        height[rank[i]]=k;

    }
}
bool check(int n,int k,int num)
{
    int ans=1;
    for(int i=2;i<=n;i++)
    {
        if(height[i]<k)
        ans=1;
        else
        ans++;
        if(ans>=num)
        return 1;
    }
        return 0;


}
int main()
{
    int n,k;
    while(~scanf("%d%d",&n,&k))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d",&key[i]);
            key[i]++;
        }
        key[n]=0;
        buildsa(key,n+1,120000);
        getheight(key,n+1);
        int l=0,r=n;
        int ans=0;
        while(l<=r)
        {
            int mid=(l+r)/2;
            if(check(n,mid,k))
            {
                ans=mid;
                l=mid+1;
            }
            else
            r=mid-1;
        }
       printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/81259796