HDU 2824 The Euler function【欧拉函数打表入门题】模板

 

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9196    Accepted Submission(s): 3867


 

Problem Description

The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

 

Input

There are several test cases. Each line has two integers a, b (2<a<b<3000000).

 

Output

Output the result of (a)+ (a+1)+....+ (b)

 

Sample Input

 

3 100

 

Sample Output

 

3042

题意:求两个数之间数的欧拉值的和

思路:欧拉打表

#include<bits/stdc++.h>
using namespace std;
const int maxn=3000008;
int a[maxn];
void getph()//打标求欧拉函数
{
    for(int i=1;i<=maxn;i++)
        a[i]=i;
    for(int i=2;i<=maxn;i++)
    {
        if(a[i]==i)
        {
            for(int j=i;j<maxn;j+=i)
            {
                a[j]=a[j]/i*(i-1);
            }
        }
    }
}
int main()
{
    int n,m;

    getph();
    while(~scanf("%d%d",&n,&m))
    {
         long long ans=0;
        for(int i=n;i<=m;i++)
        {
               
            ans+=a[i];
        }
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/SunPeishuai/article/details/81502440