HDU 2824(欧拉函数)

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

链接:2824 

Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

Output
Output the result of (a)+ (a+1)+....+ (b)
 

Sample Input
 
  
3 100
 
Sample Output
 
  
3042
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2818  2825  2817  2822  2821 



代码:



#include<iostream>
using namespace std;
bool flag[3000005];
int phi[3000005]={0,1},p[3000005]={0},cnt=0;
int main()
{
    for(int i=0;i<=3000004;i++)flag[i]=1;
    for(int i=2;i<3000000;i++)
    {
        if(flag[i])
        {
            p[cnt++]=i;
            phi[i]=i-1;
        }
        for(int j=0;j<cnt;j++)
        {
            if(i*p[j]>3000000)break;
            flag[i*p[j]]=0;
            if(i%p[j]==0)
            {
                phi[i*p[j]]=p[j]*phi[i];
                break;
            }
            else phi[i*p[j]]=(p[j]-1)*phi[i];
        }
    }
    int i,x,y;
    while(cin>>x>>y)
    {
    long long ans=0;
    for(i=x;i<=y;i++)ans+=phi[i];
    cout<<ans<<endl;
}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/niuniu0205/article/details/80210273