HDU 2654 Become A Hero (欧拉函数)

Become A Hero

Lemon wants to be a hero since he was a child. Recently he is reading a book called “Where Is Hero From” written by ZTY. After reading the book, Lemon sends a letter to ZTY. Soon he recieves a reply.

Dear Lemon,
It is my way of success. Please caculate the algorithm, and secret is behind the answer. The algorithm follows:
Int Answer(Int n)
{
.......Count = 0;
.......For (I = 1; I <= n; I++)
.......{
..............If (LCM(I, n) < n * I)
....................Count++;
.......}
.......Return Count;
}
The LCM(m, n) is the lowest common multiple of m and n.
It is easy for you, isn’t it.
Please hurry up!
ZTY

What a good chance to be a hero. Lemon can not wait any longer. Please help Lemon get the answer as soon as possible.

Input
First line contains an integer T(1 <= T <= 1000000) indicates the number of test case. Then T line follows, each line contains an integer n (1 <= n <= 2000000).
Output
For each data print one line, the Answer(n).
Sample Input

1
1

Sample Output

0

题目:

Int Answer(Int n)
{
…….Count = 0;
…….For (I = 1; I <= n; I++)
…….{
…………..If (LCM(I, n) < n * I)
………………..Count++;
…….}
…….Return Count;
}
求1-n范围内与n不互质的数

分析:

求出欧拉函数来一减即可

code:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 2000010;
int phi[maxn];
void Euler(){
    phi[1] = 1;
    for(int i = 2; i < maxn; i++){
        phi[i] = i;
    }
    for(int i = 2; i < maxn; i++){
        if(phi[i] == i){
            for(int j = i; j < maxn; j += i){
                phi[j] = phi[j] / i * (i - 1);
            }
        }
    }
}
int main(){
    Euler();
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        printf("%d\n",n-phi[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/81448018