hdu2588——GCD(欧拉函数)

hdu2588——GCD
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
Output
For each test case,output the answer on a single line.
Sample Input
3
1 1
10 2
10000 72
Sample Output
1
6
260

思路:
题意大概:给定N,M(2<=N<=1000000000, 1<=M<=N), 求1<=X<=N 且gcd(X,N)>=M的个数。

解法:数据量太大,用常规方法做是行不通的。后来看了别人的解题报告说,先找出N的约数x,并且gcd(x,N)>= M,结果为所有N/x的欧拉函数之和。因为x是N的约数,所以gcd(x,N)=x >= M;
设y=N/x,y的欧拉函数为小于y且与y互质的数的个数。设与y互质的的数为p1,p2,p3,…,p4。那么gcd(x* pi,N)= x >= M。也就是说只要找出所有符合要求的y的欧拉函数之和就是答案了。

关于欧拉函数求值的知识点总结:(https://www.cnblogs.com/PJQOOO/p/3875545.html);
在这里插入图片描述

#include<iostream>
using namespace std;
int euler(int n) {
	int res=n,a=n;
	for(int i=2; i*i<=a; i++) {
		if(a%i==0) {//第一次找到的i必为素因子 
			res=res/i*(i-1);//res=res-res/i
			while(a%i==0) a/=i;//把该素因子全部约掉,相当于i的次方全部约掉 
		}
	}
	if(a>1) res=res/a*(a-1);//res=res-res/a;            
	return res;
}
int main() {
	int n,m,t;
	scanf("%d",&t);
	while(t--) {
		scanf("%d %d",&n,&m);
		int sum=0,x;
			for(int i=1; i*i<=n; i++) {
				if(n%i==0) {
					if(i>=m) sum+=euler(n/i);
					if(n/i>=m&&i!=n/i) sum+=euler(n/(n/i));////注意平方根不能重复算
				}
			}
			printf("%d\n",sum);
		}
		return 0;
	}

猜你喜欢

转载自blog.csdn.net/qq_41938789/article/details/84452399