hdu2588——GCD(欧拉函数) ʕ •ᴥ•ʔ

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2136    Accepted Submission(s): 1087


 

Problem Description

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input

The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output

For each test case,output the answer on a single line.

Sample Input

 

3 1 1 10 2 10000 72

Sample Output

 

1 6 260

Source

ECJTU 2009 Spring Contest

题意:给定N,M(2<=N<=1000000000, 1<=M<=N), 求1<=X<=N 且gcd(X,N)>=M的个数。

解法:数据量太大,用常规方法做是行不通的。先找出N的约数x,

          并且gcd(x,N)>= M,结果为所有N/x的欧拉函数之和。

          因为x是N的约数,所以gcd(x,N)=x >= M;

   设y=N/x,y的欧拉函数为小于y且与y互质的数的个数。

   设与y互质的的数为p1,p2,p3,…,p4

   那么gcd(x* pi,N)= x >= M。

          也就是说只要找出所有符合要求的y的欧拉函数之和就是答案了。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
#define N 100010
#include<map>
#define ll long long 
using namespace std;
ll pis(ll x)
{
	ll ans=x;
	for(int i=2;i*i<=x;i++)
	{
		if(x%i==0)
		{
			ans=ans/i*(i-1);
			while(x%i==0)
			x/=i;
		}
	}
	if(x>1)
		ans=ans/x*(x-1);// 判断最后那个数是不是素数 
	return ans;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n,m;
		cin>>n>>m;
		ll ans=0;
		int i;
		for(i=1;i*i<n;i++)
		{
			if(n%i==0)
			{
				if(i>=m)
			{
				ans+=pis(n/i);
			}
				if(n/i>=m)
			{
				ans+=pis(i);
			}
			}
		}
		if(i*i==n&&i>=m)
		ans+=pis(i);
		printf("%lld\n",ans);
	}
	return 0;	
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81606751