UVa 1584 Circular Sequence(模拟)

模拟策略:
化曲为直
模拟的方式有点像动态规划:
将环形序列复制模拟环的结构
再枚举出字典序最小的序列
传送门
这里写图片描述
Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence “CGAGTCAGCT”, that is, the last symbol “T” in “CGAGTCAGCT” is connected to the first symbol “C”. We always read a circular sequence in the clockwise direction. Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence.
However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear
sequences that can be obtained from a circular sequence. Your task is to find the lexicographically smallest sequence
from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is “AGCTCGAGTC”. If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).
Input
The input consists of T test cases. The number of test cases T is given on the first line of the input
file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear
sequence. Since the circular sequences are DNA sequences, only four symbols, ‘A’, ‘C’, ‘G’ and ‘T’, are
allowed. Each sequence has length at least 2 and at most 100.
Output
Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence
for the test case.
Sample Input
2
CGAGTCAGCT
CTCC
Sample Output
AGCTCGAGTC
CCCT


以CGAGTCAGCT为例:
这里写图片描述
代码:

#include <stdio.h>
#include <string.h>
using namespace std;
int main()
{
    int t;
    while(~scanf("%d\n",&t))
        while(t--)
        {
            char DNA[256];
            gets(DNA);
            int len = strlen(DNA),idx = 0;
            for(int i=0; i<len; i++)
            {
                DNA[i+len] = DNA[i];
                DNA[i+len+1] = 0;
                if(strcmp(DNA+idx,DNA+i+1)>0)
                    idx = i+1;
            }
            DNA[idx+len] = 0;
            puts(DNA+idx);
        }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/tilmant/article/details/81590553