HDU 6440 Dream (数论常识题)

Dream

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 882    Accepted Submission(s): 111
Special Judge

 

Problem Description

Freshmen frequently make an error in computing the power of a sum of real numbers, which usually origins from an incorrect equation (m+n)p=mp+np , where m,n,p are real numbers. Let's call it ``Beginner's Dream''.

For instance, (1+4)2=52=25 , but 12+42=17≠25 . Moreover, 9+16−−−−−√=25−−√=5 , which does not equal 3+4=7 .

Fortunately, in some cases when p is a prime, the identity

(m+n)p=mp+np


holds true for every pair of non-negative integers m,n which are less than p , with appropriate definitions of addition and multiplication.

You are required to redefine the rules of addition and multiplication so as to make the beginner's dream realized.

Specifically, you need to create your custom addition and multiplication, so that when making calculation with your rules the equation (m+n)p=mp+np is a valid identity for all non-negative integers m,n less than p . Power is defined as

ap={1,ap−1⋅a,p=0p>0



Obviously there exists an extremely simple solution that makes all operation just produce zero. So an extra constraint should be satisfied that there exists an integer q(0<q<p) to make the set {qk|0<k<p,k∈Z} equal to {k|0<k<p,k∈Z} . What's more, the set of non-negative integers less than p ought to be closed under the operation of your definitions.
 

Hint


Hint for sample input and output:
From the table we get 0+1=1 , and thus (0+1)2=12=1⋅1=1 . On the other hand, 02=0⋅0=0 , 12=1⋅1=1 , 02+12=0+1=1 .
They are the same.  

Input

The first line of the input contains an positive integer T(T≤30) indicating the number of test cases.

For every case, there is only one line contains an integer p(p<210) , described in the problem description above. p is guranteed to be a prime.

 

Output

For each test case, you should print 2p lines of p integers.

The j -th(1≤j≤p ) integer of i -th(1≤i≤p ) line denotes the value of (i−1)+(j−1) . The j -th(1≤j≤p ) integer of (p+i) -th(1≤i≤p ) line denotes the value of (i−1)⋅(j−1) .

 

Sample Input

 

1 2

 

Sample Output

 

0 1 1 0 0 0 0 1

 

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

 

Recommend

chendu   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

#include<cstdio>

using namespace std;
/*
题目大意:很数学的一道题,
p是质数,然后让构造两种运算+和*,
输出两个p*p的矩阵,分别代表着+和*的结果,
也就是定义域内的映射矩阵。

这道题刚开始因为对一个数论小知识不了解,,
错失良机,后期想了个感觉更厉害的构造法,
但无奈wa到自闭。。。

这道题主要还是考了个小知识,
据说证明费马小定理时都用到了。

就是如果p是质数,(m+n)^p,m^p+n^p关于p同模。

具体证明也好办,考虑下底为p的组合数即可,C(p,i).
因为p是质数,下面的阶乘是消不掉p的,所以任何这样的组合数都是p的倍数。

这道题迎刃而解。


*/

int main()
{
	int T,n;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= n; j++) {
				printf("%d ",((i - 1) + (j - 1))%n );
			}
			printf("\n");
		}
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= n; j++) {
				printf("%d ",((i - 1)*(j - 1))%n );
			}
			printf("\n");
		}
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37451344/article/details/82078678