ACM暑期集训27

补题:

Find Integer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 694    Accepted Submission(s): 83
Special Judge

 

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

 

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

 

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

 

Sample Input

 

1

2 3

 

Sample Output

 

4

5

分析:

由费马大定理可知N>=3时无解,N为1,0可简单讨论,对于N=2,这里要用到费马大定理奇偶数列法则

当a为奇数时  c-b=1   当a为偶数时  c-b=2

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
#include <stdio.h>
#include <algorithm>
using namespace std;

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		long long a,n;
		scanf("%lld%lld",&n,&a);
		if(n>=3||n==0) printf("-1 -1\n");
		else if (n==1) printf("1 %lld\n",a+1);
		else {
			long long n,b,c;
			if(a%2==1) {
				c=(a*a+1)/2;
				b=(a*a-1)/2;
				printf("%lld %lld\n",b,c);
			}
			else {

				c=(a*a+4)/4;
				b=(a*a-4)/4;
				printf("%lld %lld\n",b,c);
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41383801/article/details/82056133