1048. Find Coins (25)(C++)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

题目大意:给出的一串数字序列中有没有两个之和恰好为k

解题思路:有点效仿1044的意味,不过简单多了。排完序之后,首尾一一进行相加比较即可。

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int main(){
    int n,k;
    scanf("%d %d",&n,&k);
    std::vector<int> v(n);
    for(int i=0;i<n;i++)
        scanf("%d",&v[i]);
  int i=0,j=n-1;
    sort(v.begin(), v.end());
	while(v[i]+v[j]!=k){
		while(v[i]+v[j]>k&&i<j)
			--j;
		while(v[i]+v[j]<k&&i<j)
			++i;
		if(i==j)
			break;
	}
	if(v[i]+v[j]!=k||i==j)
		printf("No Solution");
	else
		printf("%d %d",v[i],v[j]);
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/80201365