暑假集训day9——数据结构实验之查找一:二叉排序树

数据结构实验之查找一:二叉排序树

Time Limit: 400 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

Sample Input

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

Sample Output

Yes
No
No

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct node
{
    char data;
    struct node *l, *r;
};

struct node *creat(struct node *root, int x)
{
   if(!root)
   {
       root = (struct node*)malloc(sizeof(struct node));
       root-> data = x;

       root-> l = NULL;
       root-> r = NULL;
   }

   else
   {
       if(root-> data > x)
       {
           root-> l = creat(root-> l, x);
       }

       else
       {
           root-> r = creat(root-> r, x);
       }
   }

   return root;
}

int search(struct node *root, struct node *root1)
{
   if(root == NULL && root1 == NULL)
   {
       return 1;
   }

   else
   {
       if(root-> data == root1-> data)
       {
           if(search(root-> l, root1-> l) && search(root-> r, root1-> r))
           {
               return 1;
           }

           else
           {
               return 0;
           }
       }

       else
       {
           return 0;
       }
   }
}

int main(void)
{
    int k, x, n, i, t;
    struct node *root, *root1;

    while(~scanf("%d", &n) && n != 0)
    {
        scanf("%d", &k);
        root = NULL;
        for(i = 0; i < n; i++)
        {
            scanf("%d", &x);
            root = creat(root, x);
        }

        while(k--)
        {
             root1 = NULL;
            for(i = 0; i < n; i++)
            {
                scanf("%d", &x);
                root1 = creat(root1, x);
            }

            t = search(root, root1);

            if(t)
            {
                printf("Yes\n");
            }

            else
            {
                printf("No\n");
            }
        }


    }

    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/Eider1998/article/details/81531036
今日推荐