暑假集训day9——二叉排序树

二叉排序树

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

二叉排序树的定义是:或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值; 若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值; 它的左、右子树也分别为二叉排序树。 今天我们要判断两序列是否为同一二叉排序树

Input

开始一个数n,(1<=n<=20) 表示有n个需要判断,n= 0 的时候输入结束。

接下去一行是一个序列,序列长度小于10,包含(0~9)的数字,没有重复数字,根据这个序列可以构造出一颗二叉排序树。

接下去的n行有n个序列,每个序列格式跟第一个序列一样,请判断这两个序列是否能组成同一颗二叉排序树。(数据保证不会有空树)

Output

扫描二维码关注公众号,回复: 2992351 查看本文章

Sample Input

2
123456789
987654321
432156789
0

Sample Output

NO
NO

Hint

Source

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct node
{
    char data;
    struct node *l, *r;
};

char s[100], s1[100];
int len, len1;

struct node *creat(struct node *root, int x)
{
    if(!root)
    {
        root = (struct node*)malloc(sizeof(struct node));
        root-> data = x;

        root-> l = NULL;
        root-> r = NULL;
    }

    else
    {
        if(root-> data > x)
        {
            root-> l = creat(root-> l, x);
        }

        else
        {
            root-> r = creat(root-> r, x);
        }
    }

    return root;
}

int search(struct node *root, struct node *root1)
{
    if(root == NULL && root1 == NULL)
    {
        return 1;
    }

    else
    {
        if(root-> data == root1-> data)
        {
            if(search(root-> l, root1-> l) && search(root-> r, root1-> r))
            {
                return 1;
            }

            else
            {
                return 0;
            }
        }

        else
        {
            return 0;
        }
    }
}

int main(void)
{
    int x, n, i, t;
    struct node *root, *root1;

    while(~scanf("%d", &n) && n != 0)
    {
        root = NULL;

        scanf("%s", s);
        len = strlen(s);

        for(i = 0; i < len; i++)
        {
            x = s[i];
            root = creat(root, x);
        }

        while(n--)
        {
            root1 = NULL;

            scanf("%s", s1);
            len1 = strlen(s1);
            for(i = 0; i < len1; i++)
            {
                x = s1[i];
                root1 = creat(root1, x);
            }
            t = search(root, root1);

            if(t)
            {
                printf("YES\n");
            }

            else
            {
                printf("NO\n");
            }
        }


    }

    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/Eider1998/article/details/81531272
今日推荐