POJ2155 Matrix【二维树状数组】

Matrix

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 33133   Accepted: 11997

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

问题链接POJ2155 Matrix

问题描述:(略)

问题分析

  这是一个二维树状数组的模板题,不解释。

程序说明:(略)

参考链接:(略)

题记:(略)

AC的C++语言程序如下:

/* POJ2155 Matrix */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 1000;
int n, a[N + 1][N + 1];

inline int lowbit(int k)
{
    return k & -k;
}

void update(int row, int col, int val) {
    for (int i = row; i <= n; i += lowbit(i)) {
        for (int j = col; j <= n; j += lowbit(j)) {
            a[i][j] += val;
        }
    }
}

int sum(int row, int col) {
    int ans = 0;
    for (int i = row; i > 0; i -= lowbit(i))
        for (int j = col; j > 0; j -= lowbit(j))
            ans += a[i][j];
    return ans;
}

int main()
{
    int x, t;
    char cmd[4];
    scanf("%d", &x);
    while(x--) {
        scanf("%d%d", &n, &t);
        memset(a, 0, sizeof(a));
        while(t--) {
            scanf("%s", cmd);
            if(cmd[0] == 'C') {
                int x1, y1, x2, y2;
                scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
                update(x1, y1, 1);
                update(x2 + 1, y1, 1);
                update(x1, y2 + 1, 1);
                update(x2 + 1, y2 + 1, 1);
            } if(cmd[0] == 'Q') {
                int x, y;
                scanf("%d%d", &x, &y);
                printf("%d\n", sum(x, y) % 2);
            }
        }

        if(x)
            printf("\n");
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/82177647
今日推荐