POJ-2155 Matrix(二维树状数组)

版权声明:如果路过的各位大佬想对菜鸡进行指点请加QQ:3360769137 https://blog.csdn.net/PleasantlY1/article/details/83719521

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

题目大意:给出一个初始0矩阵,然后进行2种操作,取反:给出2个坐标,将坐标围起来的矩阵取反。查询:给出一个点坐标,求该坐标当前的值。

思路:很典型的树状数组,但是变成了二维。普通一维修改add(l,1),add(r+1,-1)。那对应到二维中就应该是

add(x1,y1,1)      add(x1,y1+1,-1)

add(x2+1,y1,-1)     add(x2+1,y2+1,1)。画图秒懂。

代码如下:(我用输入挂会格式错误,可能是动态查询的原因?)

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#define per(i,a,b) for(int i=a;i<=b;++i) 
using namespace std;
const int MAXBUF=10000;
char buf[MAXBUF],*ps=buf,*pe=buf+1;
inline void rnext()
{
    if(++ps==pe)
        pe=(ps=buf)+fread(buf,sizeof(char),sizeof(buf)/sizeof(char),stdin);
}
template<class T>
inline bool in(T &ans)
{
    ans=0;
    T f=1;
    if(ps==pe) return false;
    do{
        rnext();
        if('-'==*ps) f=-1;
    }while(!isdigit(*ps)&&ps!=pe);
    if(ps==pe) return false;
    do
    {
        ans=(ans<<1)+(ans<<3)+*ps-48;
        rnext();
    }while(isdigit(*ps)&&ps!=pe);
    ans*=f;
    return true;
}



int n,m,tree[1010][1010];//p数组用于单点查询,区间查询不用 
int lowbit(int k)//k的二进制从最低开始连续0个数x,返回2的x次方 
{
    return k&-k;
}
void add(int x,int y,int k)//单点更新 
{
	for(int i=x;i<=n;i+=lowbit(i))
	{
		for(int j=y;j<=n;j+=lowbit(j))
		tree[i][j]+=k;
	}
}
int sum(int x,int y)//单点查询前缀和 
{
    int ans=0;
    for(int i=x;i>0;i-=lowbit(i))
    {
    	for(int j=y;j>0;j-=lowbit(j))
    	ans+=tree[i][j];
	} 
    return ans;
}
int main()
{
	int T,a,b,c,d;
	char ch;
	scanf("%d",&T);
    while(T--)
    {
	    memset(tree,0,sizeof(tree)); 
	    scanf("%d%d",&n,&m);
        while(m--)
        {
            cin>>ch;
            if(ch=='C')
            {
            	scanf("%d%d%d%d",&a,&b,&c,&d);
            	add(a,b,1);
            	add(a,d+1,-1);
            	add(c+1,b,-1);
            	add(c+1,d+1,1);
            	for(int i=1;i<=n;++i)
            	{
            		for(int j=1;j<=n;++j)
            		{
            			printf("%d ",tree[i][j]);
					}
					printf("\n");
				}
			}
			else
			{
				scanf("%d%d",&a,&b);
				printf("%d\n",sum(a,b)%2);
			}
        }
        if(T!=0) printf("\n");
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/PleasantlY1/article/details/83719521
今日推荐