Matrix (POJ-2155)

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

  1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
  2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.
Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

题意:

给出一个n * n的矩阵,初始全部为0,之后一系列操作分为把一个区间的值反相和求某个点的值两种。

思路:

二维树状数组的应用,更新时只需要更新区间的四个边角,然后查询就是求和。

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <map>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <list>
#include <cmath>
#include <algorithm>
#define MST(a, b) memset(a, b, sizeof(a))
using namespace std;
const int MAXN = 1000 + 200;
int num[MAXN][MAXN], n, T, x;
int lowbit(int x) {return x & (-x);}
void update(int x, int y) {
    for (int i = x; i <= n; i += lowbit(i))
        for (int j = y; j <= n; j += lowbit(j))
            num[i][j]++;
}
int sum(int x, int y) {
    int res = 0;
    for (int i = x; i > 0; i -= lowbit(i))
        for (int j = y; j > 0; j -= lowbit(j))
            res += num[i][j];
    return res;
}
int main() {
    ios::sync_with_stdio(false); cin.tie(0); cout.tie(0);
    cin >> x;
    while (x--) {
        cin >> n >> T;
        MST(num, 0);
        while (T--) {
            string op;
            cin >> op;
            if (op == "C") {
                int x1, y1, x2, y2;
                cin >> x1 >> y1 >> x2 >> y2;
                update(x1, y1);
                update(x1, y2 + 1);
                update(x2 + 1, y1);
                update(x2 + 1, y2 + 1);
            }
            else {
                int x1, y1;
                cin >> x1 >> y1;
                cout << sum(x1, y1) % 2 << endl;
            }
        }
        if (x) cout << endl;
    }
}

猜你喜欢

转载自blog.csdn.net/white_yasha/article/details/80773949
今日推荐