HDU 多校3 Problem F. Grab The Tree

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/jiayizhenzhenyijia/article/details/81296410

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6324

Problem Description

Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,...,n , connected by n−1 bidirectional edges. The i -th vertex has the value of wi .
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y , he can't grab both x and y . After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

 

Input

The first line of the input contains an integer T(1≤T≤20) , denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,...,wn(1≤wi≤109) , denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v , denoting a bidirectional edge between vertex u and v .

 

Output

For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

 

Sample Input

扫描二维码关注公众号,回复: 3229993 查看本文章

1 3 2 2 2 1 2 1 3

 

Sample Output

Q

题意:树上有n个顶点,由1,2,…,n标记,n-1个双向边连接。第i个顶点具有Wi的值。小Q需要抓取树上的一些顶点。他可以选择任意数量的顶点来抓取,但是不允许他抓取树上相邻的两个顶点。也就是说,如果X和Y之间有一个边,他不能同时抓住X和Y。Q移动之后,小T将抓住所有其余顶点。每个玩家的最终分数是他选择顶点的值的位异或。因为位异或的结果一定不大于两者中最大的那个,所以排序后讲最大的给小Q,剩下的全部给小T,然后比较结果。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int m[100005];
int main()
{
    int a,b,c,d,e;
    cin>>a;
    while(a--)
    {
        scanf("%d",&b);
        for(c=0;c<b;c++)
            scanf("%d",&m[c]);
        for(c=1;c<b;c++)
            scanf("%d %d",&d,&e);
        sort(m,m+b);
        d=m[0];
        for(c=1;c<b-1;c++)
            d=d^m[c];
        if(d>m[b-1])
            cout<<"T"<<endl;
        else if(d<m[b-1])
            cout<<"Q"<<endl;
        else if(d==m[b-1])
            cout<<"D"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/jiayizhenzhenyijia/article/details/81296410
今日推荐