PAT甲级 1064 Complete Binary Search Tree (30 分)完全二叉树、BST

1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

解析: 先对输入数据排序,因为BST的中序遍历结果是递增的、BST的中序遍历结果是递增的、BST的中序遍历结果是递增的(重要的事情说三遍!!!)。所以可以得到中序遍历结果

         所以肯定是通过DFS模仿中序遍历求出对应位置的数据,i位置的左子结点对应2i,右子结点对应2i+1

         最后通过BSF求出层次遍历结果

#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;

const int maxn = 1e3 + 10;
int a[maxn],b[maxn],index = 0; 
int n;

//通过中序遍历的顺利获取对应位置存储的数 
void dfs(int x){
	if(x > n)return;
	dfs(x << 1);//2x
	b[x] = a[index++];
	dfs((x << 1) | 1);//2x+1 
}

void bfs(int x){
	queue<int> que;
	que.push(x);
	while(!que.empty()){
		int p = que.front();
		que.pop();
		printf("%d%s",b[p],p==n?"":" ");
		if((p<<1) <= n)
			que.push(p<<1);
		if((p<<1 | 1) <= n)
			que.push(p<<1 | 1);
	}	
}

int main(){

	scanf("%d",&n);
	for(int i = 0;i<n;i++)
		scanf("%d",&a[i]);
	sort(a,a+n);
	dfs(1);
	bfs(1);
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82825436