PAT (Advanced Level) Practice 1064 Complete Binary Search Tree(30分)【二叉搜索树BST】

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题意

给出一个序列,要求输出这棵树的层序遍历,这棵树是完全二叉搜索树。

思路

二叉搜索树的中序遍历是有序的,所以只需要将这个序列排序就可以获得中序遍历。又因为这棵树是完全二叉树,所以每个节点的序号很容易确定。层序遍历实际上就是按照节点的序号排序。

代码

#include <algorithm>
#include <cstdio>

using namespace std;

const int MAX_SIZE = 1010;

int n, p = 0, nums[MAX_SIZE], cbt[MAX_SIZE];

void inOrder(int root) {
    if (root > n)
        return;
    inOrder(root * 2);
    cbt[root] = nums[p++];
    inOrder(root * 2 + 1);
}

int main() {
    scanf("%d", &n);
    for (int i = 0; i < n; ++i)
        scanf("%d", nums + i);

    sort(nums, nums + n);

    inOrder(1);

    for (int i = 1; i <= n; ++i) {
        printf("%d", cbt[i]);
        if (i < n)
            printf(" ");
    }
}
发布了184 篇原创文章 · 获赞 19 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Exupery_/article/details/104202323