1064 Complete Binary Search Tree (30 分)PAT (Advanced Level) Practice

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题目大意:给一串构成树的序列,已知该树是完全二叉搜索树,求它的层序遍历的序列

由于是满二叉树,用数组既可以表示
父节点是i,则左孩子是2*i,右孩子是2*i+1
另外根据二分搜索树的性质,中序遍历恰好是从小到大排序
因此先中序遍历填充节点对应的值,然后再层次遍历输出即可。

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int n;
vector<int>minorder;
void mintraver(int root)
{
	if(root>n) return;
	
	mintraver(2*root);
	minorder.push_back(root);
	mintraver(2*root+1);
}


int main()
{
	cin>>n;
	int num[1001],level[1001];
	for(int i=0;i<n;i++)
	cin>>num[i];
	
	sort(num,num+n);
	mintraver(1);
	for(int i=0;i<minorder.size();i++)
	level[minorder[i]]=num[i];
	
	for(int i=1;i<n;i++)
	cout<<level[i]<<" ";
	cout<<level[n];
	
	return 0;
}

 bfs,本来就是应用层序遍历的思想来扫的

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
#include <queue>
using namespace std;
const int maxn=1005;
int a[maxn];
int node[maxn];
int cnt=0;
void build(int root,int n){
    if(cnt>n)
        return;
    if(root>n)
        return;
    build(root<<1,n);
    node[root]=a[++cnt];
//printf("id:%d val:%d\n",root,node[root]);
    build((root<<1)|1,n);
}
void BFS(int root,int n){
    queue<int> q;
    q.push(root);
    int v;
    bool first=true;
    while(!q.empty()){
        v=q.front();
        q.pop();
        if(first){
            first=false;
            printf("%d",node[v]);
        }
        else
            printf(" %d",node[v]);
        if(v*2<=n)
            q.push(v*2);
        if(v*2+1<=n)
            q.push(v*2+1);
    }

}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    sort(a+1,a+n+1);
    build(1,n);
    BFS(1,n);

    return 0;
}

猜你喜欢

转载自blog.csdn.net/mlm5678/article/details/83247575