dfs_1064 Complete Binary Search Tree (30 分)

1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题目大意

题目要求给定一个数组,给出这个数组所组成的完全二叉搜索树的层次遍历序列

二叉搜索树,左边的节点小于当前节点数值,右边节点大于当前节点数值,并且左子树右子树也是满足上面的两个条件

使用深搜,按照中序遍历的方式给树对应的位置上进行赋值

然后按照顺序输出二叉树的数组即可

#include <vector>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f

using namespace std;
const int maxn = 1005;
int a[maxn],tree[maxn*2],_index,n;

void dfs(int p)
{
    if(p > n)
        return ;
    dfs(p<<1);
    tree[p] = a[_index++];
    dfs(p<<1|1);
}
int main()
{
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)
        scanf("%d",a+i);
    sort(a,a+n);
    dfs(1);
    for(int i =1 ;i <= n;i ++)
        printf("%d%c",tree[i],i==n?'\n':' ');
    return 0;
}

猜你喜欢

转载自blog.csdn.net/li1615882553/article/details/85136493